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Step to create 
and manage 
projects
The following sections 
must be followed in 
sequential order:

Additional 
resources
AsciiDoc cheatsheet

Asciidoctor User Manual

Atlassian git tutorials

Search


Join the Docs-as-Code platform Workplace group to share 
your experience with the tools and methods and seek 
guidance.



ESweeneyT
Sticky Note
List of links with Steps were here and they were removed in the conversion from Confluence to PDF. These are the bookmarks on the left.



Docs-as-Code  –  Create and manage a project in IntelliJ

 –  4

Overview
Project files for documents are stored in a centralized (remote) repository 
that is hosted by Atlassian's Bitbucket. The following diagram explains 
the end-to-end workflow when using Git integrated in IntelliJ to manage 
documentation projects. See Docs-as-Code software platform for details.

1. Git Clone: The first time you are working with files, you must clone
the repository. Cloning creates a copy of the repository on your 
local machine. 

2. Git Pull: Every time you start work, you must pull (retrieve) the 
latest files from the remote repository. This ensures you get all the 
latest changes and the files on your local machine are in sync with 
the remote repository. You pull all the files from the repository, not 
just a specified set of files. 

3. New Branch: Before creating or updating files, you must create a 
feature branch. Think of this as a temporary container that keeps 
your work separate from everyone else's. 

4. Commit: When you are done making changes, you 
must commit your changes. Committing your changes moves 
them from your working directory to your local repository.

5. Push:  The goal is to send your changes back to the remote 
repository. To do this, you push your changes to the remote 
repository.

6. Pull (review) request: After your changes have been pushed, you 
must request that your changes are added to the main branch 
where all the integrated work is stored (called develop). Go to the 
Bitbucket URL in your web browser to create a pull request to ask 
that your changes be reviewed. You will specify the feature branch 
to let the reviewer know what they must review. After the reviewer 
approves the pull request, a moderator merges the feature branch 
to develop and the feature branch is deleted.

You only have to clone once. You do not have to do a Git 
Pull immediately following a clone.
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1 Step 1: Clone the repository (first-time only)

Clone the repository that has your project.

Let's use the following repository for our example: https://bitbucket.am.tsacorp.com/scm/id/
product_documentation.git

Steps

Additional Information

A. In IntelliJ, select Get from 
Version Control.

Example

B. In the URL field, enter your 
repository URL such as https://
bitbucket.am.tsacorp.com/scm/
id/product_documentation

Terminology tips
• For those who are used to the Bluesteam CMS, Bitbucket is like XDocs Explorer, and the content in 

Bitbucket that is referred to as the repository is like all of the files that were stored in XDocs 
Explorer.

• Generally, you can relate Projects in IntelliJ to deliverables such as documents or site help.



You will only see the 
splash screen if all 
projects are closed. 
Click File > Close 
Project to close open 
projects.
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Steps

Additional Information

C. In Directory, leave it as C:
\Users\<username>\IdeaProjec
ts\product_documentation.

Example

D. Click Clone.

If prompted, enter your network 
credentials and click Log In.

Example
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Steps

Additional Information

E. The first time you clone, you 
might get a certificate request. 
Click Accept.

Example

F. If you see the Tip of the Day, 
click Close.

If you never want to see a tip 
again, select the Don't show 
tips check box. 

Example

G. Click the Project tab on the 
left to open the Project window 
if needed. 

Example
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Steps

Additional Information

H. Select Project > Project files 
to see all the files.

Example

Note: You might have to click the arrow to the left of the 
path name to see all the files. See the second example 
image.

Example
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2 Step 2: Pull documents from the repository (required)

When you want to make a change to topics, retrieve the latest files from the centralized repository. This ensures 
that you have all the changes made by others working on a project.

Although you pull the entire repository, the Pull action is fast.

Steps

Additional Information

A. Open your project.

B. Go to VCS > Git > Pull.  Example

C. Set the repository to the 
correct branch from which to 
pull. For example, if you must 
get the latest content from the 
develop branch, change to 
develop as shown in the 
example.

Example

Skip this step the first time you are using these steps because you did a clone which pulls all the files from 
the repository. 
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Steps

Additional Information

D. Click Pull. The latest files are 
shown on the Project tab.

Example
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3 Step 3: Create a feature branch (required)

A feature branch allows you to work on a single "feature" in a dedicated branch, rather than the main branch. For 
example, Jira ID-123 says to describe a new feature. For this Jira, you must create a topic and update three topics. 
All this work will be performed on the feature branch.

A feature branch is temporary. Think of it as a container for your changes. You create the branch and make your 
changes. The feature branch essentially stores your changes until they are reviewed and merged into the main 
repository. When the changes are merged, this feature branch is deleted.

Steps

Additional Information

A. In IntelliJ, go to the VCS menu 
at the top of the window and 
select Git > Branches.

Example

Best practice
You must use a Jira to name your feature branch, for example, feature/ID-123. 

• If you do not have a Jira, you must create one.
• If your updates are the result of multiple Jiras, name the branch using one Jira and include all Jira 

numbers in the commit message.

You must include the Jira number in the commit message.
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Steps

Additional Information

B. Click + New Branch. Example

C. Type a name for the branch.

Example

Example

D. Click Create. You can see the 
branch that is checked out at the 
bottom of the page and in the 
bottom right corner.

Example

Best practice
Use "feature/" and the 
Jira number such as:  
feature/ID-122. 



When you type 
"feature/", IntelliJ says 
the branch name is 
invalid. Ignore this 
because the error 
disappears when you 
append the Jira #.



Best practice
You must use a Jira to name your feature branch, 
for example, feature/ID-123. 

• If you do not have a Jira, you must create one.
• If your updates are the result of multiple Jiras, 

name the branch using one Jira and include all 
Jira numbers in the commit message.

You must include the Jira number in the commit 
message.
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4 Step 4: Create a new project (optional)
In IntelliJ, you create projects. The following are other terms that you might call a project:

• A publication. 
• A deliverable.
• A guide.
• A manual.
• A book
• Site help.
• Online help.

Steps

Additional Information

A. Go to File > New > Directory.

Type a name for the directory 
and press Enter. 

Then, go to the templates folder.

Example

Example

Example
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Steps

Additional Information

B. From the templates folder, 
select book_template.adoc and 
topic_template.adoc, 
then right-click and select Copy 
> Copy.

Example

C. Go to the new directory, right-
click, and select Paste. When the 
Copy window opens, verify the 
To directory is correct, 
then click OK.

Examples

Examples

D. In the Add Files to Git 
window, click Cancel. 

Examples
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Steps

Additional Information

E. Double-click 
book_template.adoc. Set the 
attributes (see the Example).

Example

Key:

• R - Attribute and a value must be present.
• O - Attribute must be present but can be blank.
• x - Attribute not to be included or not applicable

Att
rib
ute

B
o
o
k

T
o
p
i
c

Description

= 
titl
e

R R This is not an attribute, but is the title of 
topic or book. Zero–level title identified 
by the leading "= ". 

:co
pyr
igh
t:

R R 2020 &copy; ACI Worldwide, Inc.

:do
cty
pe:

R x Set to book if you want to generate a 
PDF with a separate title page, TOC, and 
other pages.

:sol
uti
on:

O O Name of solution:

• ACI Speedpay
• ACI Secure eCommerce
• ACI Omni-Commerce
• ACI Digital Business Banking
• ACI Enterprise Payments Platform
• ACI Issuing
• ACI Acquiring
• ACI Fraud Management

Multiple entries are to be semicolon 
separated.

:m
od
ule:

O O
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Steps

Additional Information

Att
rib
ute

B
o
o
k

T
o
p
i
c

Description

:pr
od
uct
-
inf
o:

R R  Name of product(s) to which book/
topic applies. Can contain multiple 
semicolon separated entries in the 
format: <productname> <version> <ga 
date>; ...

:co
nte
nt-
typ
e:

O O For books, contains one of the content 
types defined here: Content type 
overview.

For topics, can be blank, topic, or task. 
Only task is required as necessary. Blank 
or topic will simply mean concept or 
reference; IOW, non-task content. 
Concepts and reference topics used in 
DITA will merge to simply be topic. 

For future, tasks will be further sub-
divided to identify personas or target 
audience or task category and 
contained in parenthesis. For example, 
task (install), task (developer), etc.

:ke
yw
ord
s:

x O Comma-separated list of keywords. Will 
be required in the future, after keyword 
methodology is defined.

:res
our
ce-
id:

x O Typically Help ID for context-sensitive 
help requirements, but can contain 
other identifying information. 
Semicolon separated.

:be
nch
ma
rk:

x O Benchmark review record in the format 
yyyy-mm (username). For ID use only.
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Steps

Additional Information

Att
rib
ute

B
o
o
k

T
o
p
i
c

Description

:en
ha
nce
d:

x O Enhanced review record in the format 
yyyy-mm (username). For ID use only.

:im
age
sdir
:

x R Used so you do not need to put absolute 
paths in each image include. In the 
standard folder structure for a module
(guide) the value for :imagesdir: will 
be ../images.

:to
c:

O x Presence in a book will ensure that a 
table of contents is generated when the 
book is generated. This is optional but 
will most likely be present except for 
special circumstances.

:to
cle
vel
s:

O x Sets the depth of the table of contents. 
For example, if this is set to 4, then 
Headings 1 through 4 will be shown in 
the TOC.
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Steps

Additional Information

F. To rename 
book_template.adoc, right-click 
the file and select Refactor > 
Rename. Type a new name for 
the book. Make sure the .adoc 
extension remains. Click 
Refactor.
 

Example

Example

G. Repeat steps E and F for the 
topic_template.adoc.

H. Copy or type the topic text as 
needed in each template. 
See Get started with AsciiDoc for 
information about settings and 
formatting in documents.

I. After some or all the topics are 
created, use include statements 
to create a table of contents.

In the book_template (or 
renamed file), type include::. to 
open a list of topics in the 
current folder. 

Example
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Steps

Additional Information

J. Select the filename for the 
topic to be included in the 
project. For example, if you want 
to create a document named 
"Colors" with the topics "Red," 
"Blue," and "Yellow": the 
book_template.adoc file would 
look as follows:

== Colors

//attributes

 
:leveloffset: 1

include::red.adoc

include::blue.adoc

include::yellow.adoc

Now, let's say you wanted to 
add subtopics below red named 
"Pink" and "Orange":

== Colors

//attributes

 
:leveloffset: 1

include::red.adoc

 
:leveloffset: 2

include::pink.adoc

include::orange.adoc

 
:leveloffset: 1

include::blue.adoc

include::yellow.adoc

Leveloffset is an 
attribute used when 
combining documents. 
Each level pushes the 
title one level down. 
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Steps

Additional Information

K. Add as many include 
statements as needed. When 
you are done, go to File > Save 
All.
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5 Step 5: Import topics into IntelliJ (optional)

Steps

Additional Information

A. In Windows File Explorer, go 
to the location where the IntelliJ 
files are stored (see Clone the 
repository step C). 

Example

B. Copy the folder from another 
location in Windows File 
Explorer to the location where 
the IntelliJ files are stored. In 
this example, the /
Merchant_Fraud folder is copied 
to the /product_documentation 
folder.

Example

Example

If you have already created the .adoc files in a text editor, you can import these files into IntelliJ. 

Make sure there is 
no .idea or .git folder 
in the originating 
folder.
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Steps

Additional Information

C. Open IntelliJ and you will see 
the folder that you added. The 
files are in red, indicating that 
they have not yet been checked 
into Git.

Example
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6 Step 6: Edit files in an existing project (optional)
Steps

Additional Information

A. Double-click a file.

B. Make the necessary changes.

C. Go to File > Save All.
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7 Step 7: Commit and push documents to the repository 
(required)

Steps

Additional Information

A. Go to VCS > Commit. This left 
panel opens.

Example

B. Expand Unversioned 
documents.

Never commit and push any files that are in the .idea folder to the repository. These are user-specific files. 
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Steps

Additional Information

C. Select the documents that 
you modified and drag them to 
the Default Changelist.

You can also right-click the files 
and select Move to Another 
Changelist. Then, in the 
window, ensure the Default 
Changelist is selected in the 
Name list and click OK.

D. Type a commit message in 
the bottom panel.

Example

Do NOT include any of 
the documents in 
the .idea folder in the 
changelist. These 
folders should not be 
checked into Git as 
they are user-specific 
files.



Best practice
This message must 
include the Jira 
number and be 
meaningful as it will be 
used to describe the 
changes to reviewers.





Docs-as-Code  –  Create and manage a project in IntelliJ

Step 7: Commit and push documents to the repository (required) –  26

Steps

Additional Information

E. At the bottom of the page, 
select the down arrow next to 
Commit and select Commit and 
Push.

If you click Commit and not 
Commit and Push, the files that 
you changed are moved from a 
working directory to your local 
repository. They are not pushed 
(sent) to the remote repository. 
If you click Commit instead of 
Commit and Push, go to VCS > 
Git > Push to push the changes. 

Example

F. When the window opens, 
confirm that the feature branch 
is the one that you created (for 
example, ID-122) and click Push. 
A message is shown in the 
bottom left to indicate if your 
push was successful.

If it was not, you can click the 
Event Log to see the error. 

Example

G. Go to File > Close Project.

Best practice
Always close your 
project when you are 
done working.
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8 Step 8: Create a pull request (required)
Use a pull request to submit your contributions to a project.

After you submit the request, reviewers (such as IDPMs or SMEs) will review and approve the changes, or request 
clarifications or modifications. After all reviewers approve the Pull Request, a moderator merges it into the develop 
branch and the changes will be available to everyone who pulls the content from the repository. 

Steps

Additional Information

A. Go to the repository, such 
as https://
bitbucket.am.tsacorp.com/scm/
id/product_documentation.

B. Click Create pull request. Example

C. After clicking Create pull 
request, the page in the 
example opens.

Example
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Steps

Additional Information

D. From the Source Select 
branch list, select the branch 
that you created previously such 
as ID-122.

Example

E. From the Destination list, 
select develop. 

Example

F. Click Continue. In the 
Description, type a description 
if necessary.

You can use this field to include 
a due date for the reviewers.

G. In the Reviewers box, type 
the names of all reviewers. This 
can be the IDPM for the project 
and/or SMEs. 

Example

Do not leave the 
Reviewers box blank.
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Steps

Additional Information

H. Click Create.
The reviewers will review the 
Pull Request and approve it, or 
request additional changes.

After the request is approved, a 
moderator will merge the 
request.
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9 Step 9: (IDPM or SME) Review a change to a document
Use the following steps to review the changes made to a file.

Steps

Additional Information

A. As a reviewer, you will receive 
an email that indicates you have 
an active pull request.

In the email, click View pull 
request. The Pull Request opens 
in Bitbucket.

Example

Example
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Steps

Additional Information

B. Click Diff to review the 
changes.

You can review the changes as shown in the following 
image.

Example

Another way to review changes is to see a side-by-side 
comparison, click the three dots, and select Side-by-side 
diff.

Example

This shows the two files side by side.

Example
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Steps

Additional Information

C. As you review the file, you will 
either approve the changes all at 
once or make comments to send 
back to the author.

In this example, if you want to 
make a comment, hold your 
cursor over the line where you 
want to add a comment. When 
the comment icon is shown, 
click it to open the Comment 
box.

Type your comment and then 
click Comment.

Example

Example

D. Click the yellow Needs 
Work icon to send the changes 
back to the author.

Example

The author receives an email that shows the file to be fixed 
and includes the comment. 

Next, the author must go into IntelliJ, ensure that they are 
on the correct feature branch (as per the Pull Request), 
make the recommended changes, and then Commit and 
Push the changes again. 

Example
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Steps

Additional Information

E. When the Pull Request is 
updated and you are ready to 
approve it, click the green check 
box to approve the request.

Your work is done.

Next, the moderator must merge 
the changes to the develop 
branch so that all users can 
access these changes.

Example
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10 Step 10: (Content author) Make requested changes to a 
document 

Use the following steps to update a file that was returned to you from your IDPM or SME because it needs additional 
updates.

Steps

Additional Information

A. If your IDPM or SME is 
recommending changes to a file 
that you created or edited, you 
will receive an email similar to 
the one in the example.

Example

B. Click View pull request to 
open Bitbucket and view details 
about the requested changes.
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Steps

Additional Information

C. In IntelliJ, make sure that you 
are on the branch that you used 
to submit the file.

Check this on the bottom right 
corner of the window. 

Then, go to the file that you 
must update.

Example

Note: If the branch is not correct, click the branch above 
and select the correct branch from the list of Local 
Branches.

Example

D. Open the file that needs work 
and make the necessary 
changes.

If you are not on the 
correct branch, click 
the branch name under 
the Local heading and 
then select Checkout.
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Steps

Additional Information

E. Make sure the file is listed 
(and selected) in the Default 
Changelist. Example

Then, update the Commit message.

Example

F. Click Commit and Push.

In the Push Commits box, click 
Push.

Your pull request already exists and is automatically 
updated. 

Example

G. The reviewer can review the 
request again and can approve 
it.

See Step 7: (IDPM or SME) 
Review a change to a document.
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11 Appendix: Remove local branches
Remote branches are deleted when your changes are merged. Because you should use local feature branches only 
once, you might want to remove them. 

Steps

Additional Information

A. Go to VCS > Git > Delete Old 
Branches.

B. Select the branches to delete 
and click Delete selected.

Example
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