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Step to create 
and manage 
projects
The following sections 
must be followed in 
sequential order:

Get help
• FAQ
• Troubleshooting

Additional 
resources

• AsciiDoc formatting
• AsciiDoc cheatsheet
• Asciidoctor User 

Manual
• Atlassian git 

tutorials

Search

Join the Docs-as-Code platform Workplace group to share your 
experience with the tools and methods and seek guidance.
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Overview
Project files for documents are stored in a centralized (remote) repository 
that is hosted by Atlassian's Bitbucket. The following diagram explains 
the end-to-end workflow when using Git integrated in IntelliJ to manage 
documentation projects. See Docs-as-Code software platform for details.

1. Git Clone: The first time you are working with files, you must clone
the repository. Cloning creates a copy of the repository on your 
local machine. 

2. Git Pull: Every time you start work, you must pull (retrieve) the 
latest files from the remote repository. This ensures you get all the 
latest changes and the files on your local machine are in sync with 
the remote repository. You pull all the files from the repository, not 
just a specified set of files. 

3. New Branch: Before creating or updating files, you must create a 
feature branch. Think of this as a temporary container that keeps 
your work separate from everyone else's. 

4. Commit: When you are done making changes, you 
must commit your changes. Committing your changes moves 
them from your working directory to your local repository.

5. Push:  The goal is to send your changes back to the remote 
repository. To do this, you push your changes to the remote 
repository.

6. Pull (review) request: After your changes have been pushed, you 
must request that your changes are added to the main branch 
where all the integrated work is stored (called develop). Go to the 
Bitbucket URL in your web browser to create a pull request to ask 
that your changes be reviewed. You will specify the feature branch 
to let the reviewer know what they must review. After the reviewer 
approves the pull request, a moderator merges the feature branch 
to develop and the feature branch is deleted from the remote 
repository.

You only have to clone once. You do not have to do a Git 
Pull immediately following a clone.
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1 Step 1: Clone the repository (first-time only)

Clone the repository that has your project.

Steps

Additional Information

A. In IntelliJ, select Get from 
Version Control.

Example

B. In the URL field, enter your 
repository URL such as https://
bitbucket/
product_documentation

Terminology tips
• For those who are used to the Bluesteam CMS, Bitbucket is like XDocs Explorer, and the content in

Bitbucket that is referred to as the repository is like all of the files that were stored in XDocs 
Explorer.

• Generally, you can relate Projects in IntelliJ to deliverables such as documents or site help.



Some newer versions 
have a different splash 
screen. The option 
might be at the top 
right of the page and 
say Get from VCS.



You will only see the 
splash screen if all 
projects are closed. 
Click File > Close 
Project to close open 
projects.
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Steps

Additional Information

C. In Directory, leave it as C:
\Users\<username>\IdeaProjec
ts\product_documentation.

Example

D. Click Clone.

If prompted, enter your network 
credentials and click Log In.

Example
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Steps

Additional Information

E. The first time you clone, you 
might get a certificate request. 
Click Accept.

Example

F. If you see the Tip of the Day, 
click Close.

If you never want to see a tip 
again, select the Don't show 
tips check box. 

Example

G. Click the Project tab on the 
left to open the Project window 
if needed. 

Example
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Steps

Additional Information

H. Select Project > Project files
to see all the files.

Example

Note: You might have to click the arrow to the left of the 
path name to see all the files. See the second example 
image.

Example

Join the Docs-as-Code platform Workplace group to share your experience with the tools and methods 
and seek guidance.
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2 Step 2: Pull documents from the repository (required)

When you want to make a change to topics, retrieve the latest files from the centralized repository. This ensures 
that you have the latest version of the remote repository which includes all the changes made by others working on 
a project.

Although you pull the entire repository, the Pull action is fast.

Steps

Additional Information

A. Open your project.

B. If you are not already on the 
develop branch, change your 
branch to develop. Click on the 
branch in the bottom right 
corner. When it expands, under 
Remote Branches, select 
origin/develop > Checkout.

Example

Skip this step the first time you are using these steps because you did a clone which pulls all the files from 
the repository. 
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Steps

Additional Information

C. Go to VCS > Git > Pull.  Example

D. Set the repository to the 
develop branch so you pull all 
the content from the remote 
repository.

Example

If you have a newer 
version of IntelliJ, the 
menu might be Git > 
Pull. You will not have 
the VCS menu and can 
drop this from the rest 
of the instructions.



Do not pull from 
another branch.



You cannot pull specific 
content from the 
repository. It must be 
the entire repository.
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Steps

Additional Information

E. Click Pull. The latest files are 
shown on the Project tab.

Example

Join the Docs-as-Code platform Workplace group to share your experience with the tools and methods 
and seek guidance.
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3 Step 3: Create a feature branch (required)

A feature branch allows you to work on a single "feature" in a dedicated branch, rather than the main branch. For 
example, Jira ID-123 says to describe a new feature. For this Jira, you must create a topic and update three topics. 
All this work will be performed on the feature branch.

A feature branch is temporary. Think of it as a container for your changes. You create the branch and make your 
changes. The feature branch essentially stores your changes until they are reviewed and merged into the main 
repository. When the changes are merged, this feature branch is deleted.

Steps

Additional Information

A. In IntelliJ, go to the VCS menu 
at the top of the window and 
select Git > Branches.

Example

Best practice
You must use a Jira to name your feature branch, for example, feature/ID-123. 

• If you do not have a Jira, you must create one.
• If your updates are the result of multiple Jiras, name the branch using one Jira and include all Jira 

numbers in the commit message.

You must include the Jira number in the commit message.



If you have a newer 
version of IntelliJ, the 
menu might be Git > 
Branches. You will not 
have the VCS menu 
and can drop this from 
the rest of the 
instructions.
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Steps

Additional Information

B. Click + New Branch. Example

C. Type a name for the branch.

Example

Example

D. Click Create. You can see the 
branch that is checked out at the 
bottom of the page and in the 
bottom right corner.

Example

Best practice
Use "feature/" and the 
Jira number such as:  
feature/ID-122. 



When you type 
"feature/", IntelliJ says 
the branch name is 
invalid. Ignore this 
because the error 
disappears when you 
append the Jira #.
You must name the 
feature branch 
properly otherwise you 
might run into issues 
with your push to the 
remote repository.



Best practice
You must use a Jira to name your feature branch, 
for example, feature/ID-123. 

• If you do not have a Jira, you must create one.
• If your updates are the result of multiple Jiras, 

name the branch using one Jira and include all 
Jira numbers in the commit message.

You must include the Jira number in the commit 
message.
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Join the Docs-as-Code platform Workplace group to share your experience with the tools and methods 
and seek guidance.
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4 Step 4: Create a new project (optional)
In IntelliJ, you create projects. The following are other terms that you might call a project:

• A publication. 
• A deliverable.
• A guide.
• A manual.
• A book
• Site help.
• Online help.

The following steps describe how to create a new directory for a project, create a book template (_index.adoc) 
which contains the Table of Contents, and how to create a topic.

Steps

Additional Information

A. Go to File > New > Directory.

Type a name for the directory 
and press Enter. 

Then, go to the templates folder.

Example

Example

Example
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Steps

Additional Information

B. From the templates folder, 
select book_template.adoc to 
create the Table of Contents and 
topic_template.adoc to create 
a topic. Right-click and select 
Copy > Copy.

Example

C. Go to the new directory, right-
click, and select Paste. When the 
Copy window opens, verify the 
To directory is correct, 
then click OK.

Examples

Examples

D. In the Add Files to Git 
window, click Cancel. 

Examples
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Steps

Additional Information

E. Double-click 
book_template.adoc.

Set the attributes (see the 
Example). Note: These are still 
being defined.

Example

Key:

• R - Attribute and a value must be present.
• O - Attribute must be present but can be blank.
• x - Attribute not to be included or not applicable

Att
rib
ute

B
o
o
k

T
o
p
i
c

Description

= 
titl
e

R R This is not an attribute, but is the title of 
topic or book. Zero–level title identified 
by the leading "= ". 

:co
pyr
igh
t:

R R 2021 &copy; ACI Worldwide, Inc.

:do
cty
pe:

R x Set to book if you want to generate a 
PDF with a separate title page, TOC, and 
other pages.

:sol
uti
on:

O O Name of solution:

•

Multiple entries are to be semicolon 
separated.

:m
od
ule:

O O
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Steps

Additional Information

Att
rib
ute

B
o
o
k

T
o
p
i
c

Description

:pr
od
uct
-
inf
o:

R R  Name of product(s) to which book/
topic applies. Can contain multiple 
semicolon separated entries in the 
format: <productname> <version> <ga 
date>; ...

:co
nte
nt-
typ
e:

O O For books, contains one of the content 
types defined here: Content type 
overview.

For topics, can be blank, topic, or task. 
Only task is required as necessary. Blank 
or topic will simply mean concept or 
reference; IOW, non-task content. 
Concepts and reference topics used in 
DITA will merge to simply be topic. 

For future, tasks will be further sub-
divided to identify personas or target 
audience or task category and 
contained in parenthesis. For example, 
task (install), task (developer), etc.

:ke
yw
ord
s:

x O Comma-separated list of keywords. Will 
be required in the future, after keyword 
methodology is defined.

:res
our
ce-
id:

x O Typically Help ID for context-sensitive 
help requirements, but can contain 
other identifying information. 
Semicolon separated.

:be
nch
ma
rk:

x O Benchmark review record in the format 
yyyy-mm (username). For ID use only.
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Steps

Additional Information

Att
rib
ute

B
o
o
k

T
o
p
i
c

Description

:en
ha
nce
d:

x O Enhanced review record in the format 
yyyy-mm (username). For ID use only.

:im
age
sdir
:

x R Used so you do not need to put absolute 
paths in each image include. In the 
standard folder structure for a module
(guide) the value for :imagesdir: will 
be ../images.

:to
c:

O x Presence in a book will ensure that a 
table of contents is generated when the 
book is generated. This is optional but 
will most likely be present except for 
special circumstances.

:to
cle
vel
s:

O x Sets the depth of the table of contents. 
For example, if this is set to 4, then 
Headings 1 through 4 will be shown in 
the TOC.

:se
ctn
um
s:

TBD

:se
ctn
um
lev
els:

TBD

:ch
apt
er-
lab
el:

TBD
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Steps

Additional Information

F. To rename a file, right-click 
the file and select Refactor > 
Rename. Type the new name for 
the file. Click Refactor.
 

Example

Example

Best practice
Always rename the 
book template file 
to _index.adoc. This 
helps with automated 
publishing
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Steps

Additional Information

G. To create a new topic, repeat 
copy the topic_template.adoc 
again and then repeat steps C, 
D, and F.

Best practice
When naming topic 
files:

• The filename must 
use underscores.

• You must add 
the .adoc extensio
n.

• Filenames must be 
clear.

• Filenames must be 
less than 255 
characters.

For example, if the 
topic is about the 
Automated 
patching process, 
the filename 
is: automated_pat
ching_process.a
doc
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Steps

Additional Information

H. Copy or type the topic text as 
needed in each template.

• Change the Topic title at the 
top of the page to the title of 
the topic.

• For basic formatting 
information, see AsciiDoc 
formatting. For more 
information, see 
the Asciidoctor User Manual.

• For images:
• If you are adding 

existing images: 
Drag and drop 
the images 
(.png, .svg. or 
EXISTING .jpg) to 
the images 
folder.

• If you are 
creating 
diagrams, 
see Create and 
edit images.

Example

Example

Attributes and initial formatting for topics

= Topic title

:copyright:  Inc.

:solution:

:module:

:product-info:

:content-type: topic

:keywords:

:resource-id:

:benchmark: yyyy-mm (username)

:enhanced: yyyy-mm (username)

:imagesdir: ../images

 
Start adding text here.

 
* Bullet 1

* Bullet 2

** Bullet a

** Bullet b

* Bullet 3

 
image::flow.svg[high-level flow,width=600]

Tip
Each file must start 
with a level 1 heading 
and the headings must 
follow in sequential 
order. For example, you 
cannot skip from a 
heading 1 to a heading 
3. If you don't do this, 
your Table of Contents 
will break.
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Steps

Additional Information

• To insert the 
image in the text, 
use the following 
formatting where 
<imagename.svg
> is replaced with 
the filename for 
the image and 
<alternatetext> is 
replaced with the 
alt text for the 
image: 
image::<image
name.svg>[<al
ternatetext>,
width=600]
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Steps

Additional Information

I. After some or all the topics are 
created, create the Table of 
Contents using include 
statements in _index.adoc. Put 
these statements after the 
attributes. Example

= Document title

:copyright:   Inc.

:doctype: book

:toc: left

:toclevels: 3

:solution:

:module:

:product-info:

:content-type:

:imagesdir: ../images

:keywords:

:sectnums:

:sectnumlevels: 3

:chapter-label: Section

:imagesdir: ../images

 
//includes the first notices topic

include::../../../../reusable_content/

notices11.adoc[]

 

//adds a page break

<<<

 

//includes a Document revision history page if there 

is one. You might have to update the filename

:leveloffset: -1

include::DocumentRevisionHistory.adoc[]

 

//includes an About this publication page if there is 

one. You might have to update the filename

include::About_this_publication.adoc[]

 

//adds a page break

<<<

 

:leveloffset: 1

In AsciiDoc, two forward slashes (//) indicates a 
comment. The text following this is not shown in 
the final output.
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Steps

Additional Information
 

//includes an Overview page if there is one. You 

might have to update the filename

include::Overview.adoc[]

The following is an example of a document named "Colors" 
with the topics "Red," "Blue," and "Yellow." The 
book_template.adoc file would look as follows:

== Title

[attributes list would be here]

 
:leveloffset: 1

include::red.adoc[]

include::blue.adoc[]

include::yellow.adoc[]

Now, let's say you wanted to add subtopics below red 
named "Pink" and "Orange":

== Title

[attributes list would be here]

 
:leveloffset: 1

include::red.adoc[]

 
:leveloffset: 2

include::pink.adoc

include::orange.adoc[]

 
:leveloffset: 1

include::blue.adoc

include::yellow.adoc[]

Leveloffset is an attribute used when combining 
documents. Each level pushes the title one level 
down. 
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Steps

Additional Information

J. Add as many include 
statements as needed. When 
you are done, go to File > Save 
All.

Join the Docs-as-Code platform Workplace group to share your experience with the tools and methods 
and seek guidance.
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5 Step 5: Import topics into IntelliJ (optional)

Steps

Additional Information

A. In Windows File Explorer, go 
to the location where the IntelliJ 
files are stored (see Clone the 
repository step C). 

Example

B. Copy the folder from another 
location in Windows File 
Explorer to the location where 
the IntelliJ files are stored. In 
this example, the /
Merchant_Fraud folder is copied 
to the /product_documentation 
folder.

Example

Example

If you have already created the .adoc files in a text editor, you can import these files into IntelliJ. 

Make sure there is 
no .idea or .git folder 
in the originating 
folder.
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Steps

Additional Information

C. Open IntelliJ and you will see 
the folder that you added. The 
files are in red, indicating that 
they have not yet been checked 
into Git.

Example

Join the Docs-as-Code platform Workplace group to share your experience with the tools and methods 
and seek guidance.
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6 Step 6: Edit files in an existing project (optional)
Steps

Additional Information

A. Double-click a file.

B. Make the necessary changes. The editor uses color to indicate the types of changes made 
to your working directory next to the line number. For 
example:

• blue = line modified
• gray triangle = line deleted
• green = line added 

Example
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Steps

Additional Information

C. If you want to review all of 
your changes, go to the Commit
tab on the left,  and click Show 
Diff. (See the Example on the 
right for the icon.)

Example

Example

D. The right pane, which shows 
your updates, is a full editor. You 
can make additional changes.

Click >> next to any lines for 
which you want to revert the 
changes.

You can click the check boxes 
next to the individual lines to 
include in the commit. Or, 
simply close the window after 
making any changes.

E. Go to File > Save All.

If there is more than 
one file in the Default 
Changelist, select the 
file to review.
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Join the Docs-as-Code platform Workplace group to share your experience with the tools and methods 
and seek guidance.
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7 Step 7: Commit and push documents to the repository 
(required)

Steps

Additional Information

A. Go to VCS > Commit. This left 
panel opens.

Example

B. Expand Unversioned 
documents.

Never commit and push any files that are in the .idea folder to the repository. These are user-specific files. 

If you have a newer 
version of IntelliJ, the 
menu might be Git > 
Commit. You will not 
have the VCS menu 
and can drop this from 
the rest of the 
instructions.
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Steps

Additional Information

C. Select the documents that 
you modified and drag them to 
the Default Changelist. Then, 
select the files to commit.

Alternative: You can also right-
click the files and select Move to 
Another Changelist. Then, in 
the window, ensure the Default 
Changelist is selected in the 
Name list and click OK. Then, 
select the files to commit.

Do NOT include any of 
the documents in 
the .idea folder in the 
changelist. These 
folders should not be 
checked into Git as 
they are user-specific 
files.
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Steps

Additional Information

D. Type a commit message in 
the bottom panel.

Example

Best practice
This message must 
include only the Jira 
number in square 
brackets. If this is not 
correct, the push to the 
remote repository will 
fail.
If the feature branch is 
named with the Jira 
number and has a 
letter or word 
appended, do NOT 
include the appended 
text in the commit 
message.

Featur
e Name

Commit 
message

feature
/
ID-1234
a

[ID-1234] 
Your 
commit 
message

feature
/
ID-1234

[ID-1234] 
Your 
commit 
message

The message should be 
meaningful as it will be 
used to describe the 
changes to reviewers.
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Steps

Additional Information

E. At the bottom of the page, 
click Commit.

The files that you changed are 
moved from a working directory 
to your local repository. 

Example

F. Go to VCS > Git > Pull and 
click Pull.

If there are any conflicts, the 
Conflicts window opens. Click 
Merge. See Merge issues 
(conflicts) for details.

Example

G. Go to VCS > Git > Push. Click 
Push to send your files to the 
remote repository. Example
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Steps

Additional Information

H. When the window opens, 
confirm that the feature branch 
is the one that you created (for 
example, ID-122) and click Push. 
A message is shown in the 
bottom left to indicate if your 
push was successful.

If it was not, you can click the 
Event Log to see the error. 
See Troubleshooting old for any 
issues.

Example

In some cases, your 
push might fail if Git 
merged files. You will 
see a message like the 
following EXTRACT:

remote: To see the 

commit message: 

remote: 

remote: git show -

s f6fa197483c87b22 

remote: 

remote: To edit 

the commit 

message: 

remote: 

remote: git commit 

--amend 

You can fix this quickly 
by copying the line: git 
commit --amend and 
pasting it into the 
Terminal window (click 
the tab at the bottom 
of the page). Then, 
press Enter. When 
Notepad++ opens, on 
the first line of the file, 
add the Jira number in 
square brackets like:
Example
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Steps

Additional Information

I. Go to File > Close Project.

Close Notepad++ and 
push again.
See Push issues if you 
need more details.

Best practice
Always close your 
project when you are 
done working.



Join the Docs-as-Code platform Workplace group to share your experience with the tools and methods 
and seek guidance.
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8 Step 8: Create a pull request (required)
Use a pull request to submit your contributions to a project.

After you submit the request, reviewers (such as IDPMs or SMEs) will review and approve the changes, or request 
clarifications or modifications. After all reviewers approve the Pull Request, a moderator merges it into the develop 
branch and the changes will be available to everyone who pulls the content from the repository. 

See Manage reviews for guidelines.

Steps

Additional Information

A. Go to the repository, such 
as

B. Click Create pull request. Example

C. After clicking Create pull 
request, the page in the 
example opens.

Example
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Steps

Additional Information

D. From the Source Select 
branch list, select the branch 
that you created previously such 
as ID-122.

Example

E. From the Destination list, 
select develop. 

Example

F. Click Continue. 

In the Title, include a 
description that will be helpful 
to your reviewers such as the 
following:

[<Jira Number>] <Doc 
Title> 

For example:

[ID-1624] Getting 
started with  

In the Description, include a 
review by date. You can also 
include a description of the 
changes as needed.

You can use this field to include 
a due date for the reviewers.

See Manage reviews for 
additional guidelines.

Example
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Steps

Additional Information

G. In the Reviewers box, type 
the names of all reviewers. This 
can be the IDPM for the project 
and/or SMEs. 

Example

H. Click Create.
The reviewers will review the 
Pull Request and approve it, or 
request additional changes.

After the request is approved, a 
moderator will merge the 
request.

Do not leave the 
Reviewers box blank.



Join the Docs-as-Code platform Workplace group to share your experience with the tools and methods 
and seek guidance.
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9 Step 9: (IDPM or SME) Review a change to a document
Use the following steps to review the changes made to a file.

Steps

Additional Information

A. As a reviewer, you will receive 
an email that indicates you have 
an active pull request.

In the email, click View pull 
request. The Pull Request opens 
in Bitbucket. It shows a 
description of the pull request, 
the feature's commit history, 
and a diff of all the changes it 
contains.

Example

Example
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Steps

Additional Information

B. Click Diff to review the 
changes.

You can review the changes as shown in the following 
image. This is called a unified view.

Example

Another way to review changes is to see a side-by-side 
comparison, click the three dots, and select Side-by-side 
diff. 

Example

This shows the two files side by side. The file on the left is 
the old file and the file on the right is the new file. You can 
see what will be changed when the files are merged.

Press N and P on the keyboard to move between chunks of 
content in the diff.

Press Shift +N or Shift + P on the keyboard to move 
between comments.

Example

The files on the left use icons indicate the following:

Note: You can hold your mouse over the icon to see the 
action that was taken on the file.
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Steps

Additional Information

Icon Description

File was renamed

File was modified

File was added

File was removed
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Steps

Additional Information

C. As you review the file, you 
can make comments to send 
back to the author. If the author 
has questions, they can respond, 
creating a discussion about the 
work.

In this example, if you want to make a comment, hold your 
cursor over the line where you want to add a comment. 
When the comment icon is shown, click it to open the 
Comment box.

Example

Type your comment or....

Example

A quick way to make a suggested change is to click the 
Suggest a change to this line of code icon. Click Preview to 
see the change.

Example

If it is a small change such as a typo, you can make the 
change in the text as shown in the following image and then 
click Comment. You can create a task list by clicking Create 
task. The task list is shown in the upper right-hand corner 
of the pull request. Try it!

Example

Tip
You can drag images 
into comments.
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Steps

Additional Information

Click Apply suggestion to make the change immediately in 
this Pull Request.

Example

From the Apply suggestion window, click Commit 
changes. 

Example

If you applied changes, click the list to select the version 
that of the edited Pull Request.

Example
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Steps

Additional Information

D. You can also use the following 
buttons to:

• Filter file tree: filters the list 
of files by the text that you 
enter.

• Search code: searches the 
contents of the documents 
for text.

Example
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Steps

Additional Information

D. You can do one of the 
following with the Pull Request 
(PR):

1. Approve (green check 
mark)- The PR will be 
merged by the moderator.

2. Needs work (yellow icon) - 
You want the author to 
make changes to this PR and 
commit additional changes. 
The PR remains open.

3. Decline (from the 
menu) - the PR changes are 
incorrect and need a large 
amount of rework so you 
want to remove it from the 
active queue. You can 
reopen the PR, but typically, 
it is deleted.

4. Delete (from the 
menu)  - Deletes the PR from 
the queue. Any changes 
must be pushed to the 
remote repository again and 
a new PR must be created.

For this example, click the 
yellow Needs Work icon to send 
the changes back to the author.

Example

The author receives an email with a button to the Pull 
Request that has the comments from the reviewer. 

Next, the author can comment back, create a Jira issue, or 
create a follow-up task. Then, they must go into IntelliJ, 
ensure that they are on the correct feature branch (as per 
the Pull Request), make the recommended changes, and 
then Commit and Push the changes again. This commit is 
automatically added to the original Pull Request and the 
reviewer can review the changes again.

Example

E. When the Pull Request is 
updated and you are ready to 
approve it, click the green check 
box to approve the request.

Your work is done.

Next, the moderator must merge 
the changes to the develop 
branch so that all users can 
access these changes.

Example
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Join the Docs-as-Code platform Workplace group to share your experience with the tools and methods 
and seek guidance.
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10 Step 10: (Content author) Make requested changes to a 
document 

Use the following steps to update a file that was returned to you from your IDPM or SME because it needs additional 
updates.

Steps

Additional Information

A. If your IDPM or SME is 
recommending changes to a file 
that you created or edited, you 
will receive an email similar to 
the one in the example.  

Example
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Steps

Additional Information

B. Click View pull request to 
open Bitbucket and view details 
about the requested changes. 

You can do any of the following 
(or none):

• Type a comment in the 
Activity window to reply to 
the reviewer.

• Click Reply to respond to a 
specific comment from the 
reviewer. This allows you to 
have a tracked discussion.

• If a task exists, after you 
complete the work, select 
the check box to indicate 
that the work is done. See 
the examples on the right for 
more information about 
tasks and task lists.

• Click ... and you will see one 
or more of the following 
options:

• Click Convert to 
Task to convert a 
comment to a 
task which is 
shown in the list 
at the top of the 
pull request. This 
means that you 
don't have to 
search through 
comments for 
your to do items.

Example

At the top of the window, you can click the task list button:

Example

A task list opens. Click the link to go directly to the 
document that must be updated.

Example
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Steps

Additional Information

• Click Create Jira 
issue to create a 
new issue in Jira. 
This is useful if a 
change is so large 
that it must be 
tracked 
separately and 
cannot be 
completed with 
the other 
changes that you 
are currently 
working on. 

• Click Convert to 
Comment to 
convert a task to 
a comment.

Next, you must fix the content.

C. In IntelliJ, make sure that you 
are on the branch that you used 
to submit the file.

Check this on the bottom right 
corner of the window. 

Then, go to the file that you 
must update.

Example

Note: If the branch is not correct, click the branch above 
and select the correct branch from the list of Local 
Branches.

ExampleIf you are not on the 
correct branch, click 
the branch name under 
the Local heading and 
then select Checkout.
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Steps

Additional Information

D. Open the file that needs work 
and make the necessary 
changes.

E. Make sure the file is listed 
(and selected) in the Default 
Changelist. Example

Then, update the Commit message.

Example

F. Click Commit and Push.

In the Push Commits box, click 
Push.

Your pull request already exists and is automatically 
updated. 

Example

G. The reviewer can review the 
request again and can approve 
it.

See Step 7: (IDPM or SME) 
Review a change to a document.
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Join the Docs-as-Code platform Workplace group to share your experience with the tools and methods 
and seek guidance.
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11 Appendix: Working on multiple guides
Now that you have the basic flow down, you can move onto working with more advanced flows.

Scenario: As an author, you are working on multiple user guides, each with their own feature branch. This topic 
describes how to use changelists to work on multiple guides.

Changelists let you group sets of local changes and commit them independently.

Steps

Additional Information

A. When working on changes to 
a guide on a feature branch, go 
to the Commit tab, and you will 
see the changed files are listed 
in the Default Changelist.

Note: You can also access the 
Commit tab by going to VCS > 
Commit.

Example

When using changelists, be sure to commit and push the changes by the end of each working day, at a 
minimum. This ensures that your changes are available to others if you suddenly go on PTO.



If you have a newer 
version of IntelliJ, the 
menu might be Git > 
Commit. You will not 
have the VCS menu 
and can drop this from 
the rest of the 
instructions.
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Steps

Additional Information

B. If you have to switch tasks, 
create a changelist to store 
these files. To do this, right-click 
Default Changelist and select 
New Changelist. 

Example

C. In the New Changelist 
window, type a name for the 
changelist and click OK.

Example
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Steps

Additional Information

D. Select the files (click the first 
file, hold the shift key, and click 
the last file), as shown in the 
example in the right column and 
drag them to the changelist. You 
can also right-click and 
select Move to Another 
Changelist... 

If you dragged them to the other 
changelist, when the name of 
the changelist has a red box 
around it (see the second image 
in the right column), you can 
release the mouse.

Example

Example
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Steps

Additional Information

E. Now, if you have a second 
guide, go to Remote Branches > 
origin/develop > Checkout. 
Then, create your new feature 
branch and begin working on it. 

When you are done with your 
work on that feature branch, you 
can either commit and push, or 
create another changelist using 
steps A-D.

Note: If you checkout another feature branch and your 
local changes will be overwritten by the checkout, you will 
see a window like the following:

Example

Example

The window lists the files that are preventing the checkout. 

Click Force Checkout if you are ok with losing your 
uncommitted changes.
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Steps

Additional Information

Click Smart Checkout to shelve the uncommitted changes, 
check out the branch, and then unshelve the changes. If a 
conflict occurs when the changes are unshelved, you will be 
prompted to merge the changes. See IntelliJ's 
documentation for information about shelving. See Merge 
Issues for information about merging.

F. When you are ready to 
commit the changes for a 
changelist, if you are not on the 
branch whose changes you want 
to commit, first checkout that 
branch. To do this, click the 
feature branch in the bottom 
right of the IntelliJ window such 
as feature/ID-1303.

Example

G. Under Local Branches, click 
the branch to checkout, and 
from the menu select Checkout.

Example

H. Go to the changelist with the 
changes that you want to check-
in and expand it. In this 
example, the changelist is 
ID-1343 Postgres doc.

Example
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Steps

Additional Information

I. Select the check box for the 
changelist. It selects all the files. 
Type a commit message and 
commit and push as normal.

Example

J. You can repeat steps F 
through I to commit any 
changelist.

Reminder, the commit 
message must start 
with the Jira number in 
square brackets like:
[ID-1234] Commit 
message



Join the Docs-as-Code platform Workplace group to share your experience with the tools and methods 
and seek guidance.
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12 Appendix: Remove local branches
Remote branches are deleted when your changes are merged. Because you should use local feature branches only 
once, you might want to remove them. 

Steps

Additional Information

A. Go to VCS > Git > Delete Old 
Branches.

B. Select the branches to delete 
and click Delete selected.

Example

You must have the Git 
branch cleaner plugin 
installed. See the 
"Install IntelliJ" section 
in Install and configure 
Docs-as-Code platform.



If you have a newer 
version of IntelliJ, right-
click any project file 
and select Git > Delete 
old branches.



Join the Docs-as-Code platform Workplace group to share your experience with the tools and methods 
and seek guidance.
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13 Appendix: Working on the same branch
Now that you have the basic flow down, you can move onto working with more advanced flows.

13.1 Scenarios:
1. You worked on Jira # ID-1343 earlier today and created a Pull Request. It hasn't yet been merged. Now, you 

have updates to make using the same Jira #. What do you do?
2. You worked on Jira # ID-1343 yesterday and created a Pull Request. It was reviewed and merged by a 

moderator. Now, you have updates to make using the same Jira #. What do you do?
3. You worked on Jira #ID-1343 earlier and committed the files, but then went to do another task. Now, you 

need to make changes for Jira #1343 again. What do you do?

Local branches will remain unless you delete them. So, you can reuse a branch if you like. Only remote branches are 
deleted when the changes are merged. 

Steps

Additional Information

A. In the bottom, right corner of 
IntelliJ, go to Remote Branches 
> origin/develop > Checkout. 
Then, do a Git pull before you 
begin working.

Example
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Steps

Additional Information

B. In IntelliJ, go to VCS > Git > 
Branches.

Example

C. From the Git Branches 
window, click the branch under 
Local Branches that you want 
to work on and then select 
Checkout.

Example

D. Modify the files as needed, 
and then commit and push the 
changes as per the standard 
process.

If you have a newer 
version of IntelliJ, the 
menu might be Git > 
Branches. You will not 
have the VCS menu 
and can drop this from 
the rest of the 
instructions.
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